Post Feed
Comment Feed

About Me

My MP3 Player

Harry Potter and the Order of the Phoenix - (audio book) I am Legend - (audio book) Coldplay - Parachutes Harry Potter and the Goblet of Fire - (audio book)

New Comments

2017 Archives

July All Archives...

Jeep Fuel Problems

Friday, September 26th, 2008

My Cherokee ended up needing a new fuel pump recently and the whole situation was rather inconvenient.

Back in August it failed to start for the first time ever when I went to drive home after work. It would just crank and crank. I poked around for a little while and figured the problem was fuel related. I had compression because the engine was cranking at its usual speed and I had spark because I pulled a plug wire off to test it (shocking the hell out of myself in the process). The only other thing required for that car to run is fuel. When you first turn the key to the on position the fuel pump is supposed to turn on for about one second and then turn off. I couldn't hear it turning on at all when turning the key. I took a look at the wiring, which all looked ok and checked the fuel pump relay which seemed to function properly, so logically it was a fuel pump. Since I was in Harley's parking lot on a hill I really didn't want to get into changing this part myself. The pump is inside the gas tank and not very easy to get at, especially with an almost full tank of gas.

I had the car towed to a shop I've used before for them to fix it. The next day they went to check out the car and it started right up! I talked to my dad who said from his experience fuel pumps tend to start getting weak and not able to keep up under high demand, like going up hill on the highway. He also said he didn't think they would start working again if they fail. So instead of spending $400 to replace a pump that was working at the time I took the car home.

Fast-forward to last week: I was driving home from work on 31F and just as I was passing the Wegmans in East Rochester my car seemed to lose some steam for a second and then came back. I kept going, but just as I crossed the canal entering Fairport the engine died completely. I can think of worse places to break down, but Church Street in Fairport is a busy road and at rush hour is even worse! Again I sniffed around for while and couldn't hear the pump turning on. I could hear the relay clicking on and off though, so I knew it was getting power. I climbed under the car and banged on the gas tank a bunch of times hopefully trying to shock the pump into working again. No dice. I had it towed to a local shop to replace the pump.

The next day when the shop went to look at the car, it started right up (surprise, surprise). I talked to the guy and told him all the diagnosing I did, and he said it sounds like a pump, but they couldn't guaranty that since they couldn't reproduce the problem. They ordered the pump from the Jeep dealer and four days later when it arrived it was the wrong pump! The dealer only had a listing for a mechanical pump and my car has an electric pump. Since the dealer didn't have a part, they got a cheap aftermarket one from a local parts place. They put it in and it died about 5 seconds after the car started. Then they put in a much more expensive Bosch pump which worked fine.

It kills me to spend this kind of money for something that I'm not 100% sure will fix it, but what choice do I really have? I can't keep driving it until it fails on the road leaving me stranded. With my luck it'll do that in some deserted area in the middle of a blizzard. I'm really going to be pissed if that thing dies on me again with the same symptoms. At least the shop that did it has a 1 year warranty on the part and the labor if it fails again.

I have the old pump and plan on taking it apart to see why it failed, I just haven't had time yet.

broken down on W Church St.

My poor jeep stuck on the side of the road :(

Comments (9) Subscribe

Kooter
#1 - Sep 26, 2008 at 10:00 AM
Oh no! Cliff and I had our early 90s tahoe fuel pump die last december in rhode island on the center lane of a bridge in a monster snow storm...The RI state trooper then "bumped" our sorry butts off the highway with their crown vic...i was relatively sure i was going to die..
I know its probably blasphemous to say this but are you looking into a new(er?) jeep
Joe
#2 - Sep 26, 2008 at 12:46 PM
Yeah, I guess it could have been worse. I've got my dad looking for something else for me. It's rather annoying, it's a good car with low mileage for it's age (133k) and it's easy to fix. The problem is just that parts are getting harder and harder to find.
Manda
#3 - Sep 26, 2008 at 10:32 PM
Aw. Poor Beej.
:-(
JR
#4 - Sep 26, 2008 at 10:48 PM
Our fuel pump seems to be going too. It'll start just fine, but once you shut it off it's hard to get started again within the next 15 minutes or so. It's only really a problem when we're running errands and need to stop the car for a few minutes at each store. We haven't had any problems with the pump giving out while driving though.
Joe
#5 - Sep 29, 2008 at 6:41 AM
Here are the pictures of the fuel pump:


Note the manufacture date. This pump looks pretty good to me for something that is older than most college students these days.




This is the pump mechanism. The gears are in great shape; no even wearing, no flat spots and still work very smoothly. One of my dad's theories was that these gears were getting hung up because of crud or they were wearing unevenly and getting jammed. Doesn't look like the case...



Dad's #2 theory was commutator problems. This is the bottom of the motor where two contacts supply +12 volts and ground to opposite pie pieces causing it to spin (driving the gears from above). He thought maybe the commutator was worn out and didn't have enough copper left to conduct the current required or that the springs pushing the contacts against the commutator were too tired to make a good connection. It looks like there is plenty of copper, but it's worn some very deep grooves. The contacts have the same grooves (in opposite) and when aligned have very good surface area and a good connection. I think the motor was failing when the contacts somehow got out of alignment with those grooves and suddenly couldn't make a good enough connection to supply the required current.

Betsy
#6 - Sep 29, 2008 at 9:40 AM
John replaced the fuel pump on his silverado. He got the part new on ebay and it cost him like 1/3 of the retail price. it didn't take him very long to put on either.
Joe
#7 - Sep 29, 2008 at 10:44 AM
Yeah the guy who changed mine said the job wasn't as bad as he thought it would be, so I probably could have done it myself if I had another car to work with in the mean time.

I went the ebay route when I had to replace my parking brake. The part was only available locally via the dealer who wanted $200 for it, but I found it on ebay for $20.
Cheryl
#8 - Sep 30, 2008 at 6:44 PM
The only recent problem I have had with my 05 explorer was that I had to put 2 new tires on the rear because one had a hole near the sidewall and the patch the dealer had done wasn't holding. So after driving it with just 2 new tires on the rear (I was needing 4 for the winter anyway), it screwed with the computer for the control-trac feature and I was getting some slipping and whining from the transfer case. Thought my trans was going. Took it back to the dealer and they had it happen to them and the mechanic had dealt with a same thing on another explorer so he knew exactly what it was and it was fine when you put it into the 4 wheel high. So I ended up putting the other 2 new tires on it to solve the problem. I was hoping to make it to the end of October when I had some money coming, but you know the deal with that. I did it now because my sister and I had to make 2 emergency trips to VA this month with my truck, so I wanted to make sure I had no problems with it.
Joe
#9 - Oct 2, 2008 at 11:39 AM

Sidewall punctures are no good, there is almost no way to patch them reliably. I would know, I put a screw through the sidewall of the donut in the trunk of my 'opaz when I was messing around with the stereo back in high school.
It kind of sounds like they put wrong size tires on the back, like they have either a slightly different rolling radius or circumference. That would definitely screw with your computer and make the transfer case unhappy (but only in 4wd). Maybe in 2wd your front is engaged all the way back to the xfer case. Who knows.

Make a comment!

Name
Numbers from below

Comment

Email Address

Website URL


Remember me